HT-301 Thermal Camera and Picture in Picture

Yes, it is indeed working. i disconnected the CSI connection and put the air.txt in the bootpartition.
Now I can see the thermal video feed on the GroundPi
So the pipeline is correct when the thermal camera is connected as /dev/video0.

I took a look to your config; it seems to be well configured… joint in the telegram group, there are a lot of people much more expert than me! :sweat_smile:

Actually i didn’t want to create an extra account for telegram. But I’m considering it, when get completely stuck with this problem.
But apart from this, when i get this running, everybody can read it on this forum without the need of an extra account.

So when we assume that both camera streams are working, then the only problem left is the switching between the feeds.
I could imagine, that the RC input is maybe not working correctly yet, also because the bandwidth doesn’t change when I try to switch the streams.

OK, I remember Atheros card was a bit tricky to get it running. Do you have a second ar9271 card on ground? IIRC it worked when I used two atheros cards on ground (it doesn’t make any sense, but that was my workaround. And try to enter your ground cards Mac address in the settings file (both air and ground) .

After having much trouble with ar9271 cards and overcrowded wifi I use for a longer time RTL8812AU cards (AC56) and with those I get it working with only one card each. So, if you have a spare card around, give it a try. But maybe this was all working suddenly back then by accident.

Unfortunately no, these are the only two that I have.

I could try it with 2 Edimax WiFi dongles to see if it ill work. They have also the RTL8812AU chipset.

A funny thing that I just have noticed was, that when I power off my Taranis, the AirPi is trying switching cameras:

the first switch occured when I powered it off and the second one when I powered it back on.
But the assigned RC channels for actually switching something, are still not working.
And to burn away any hope, the switching that I have seen on the AirPi’s debug console does not really switched something. On the GroundPi I still see the primary feed even when the AirPi says that it had switched something…

I thought the reason for this can be that when the RC is not connected, the receiver will trigger the failsafe and cuts all RC channels to 875
2021-02-17 17_50_52-Mission Planner 1.3.72 build 1.3.7463.24854

and when it is connected it will look like this:
2021-02-17 17_51_27-Mission Planner 1.3.72 build 1.3.7463.24854

and I have checked the range that is configured for camera switching in Camera1ValueMin, whose values were used by the Camera Switcher
and this looks like this:



and all values are in the range of what they should.
So actually the AirPi should check the channel 8 and switch the cameras, but it basically ignore this channel. But I have also the channels 13 - 16 that are constantly on 1500 (which would be in the range for camera 2) because my crossfire receiver can only output 12 channels.
and on failsafe it also cuts down to 875 which would be in the range of camera 1.
and that is an interesting coincident :smiley: because every time I power off the transmitter the AirPi Switches to camera 1 and when I turn it back on it switches to camera 2.

So the AirPi is like ignoring my channel assignment and using channels that I can’t access.

this could be a plausible reason for thing to not work at all.

But the GroundPi is still on camera feed 1 though…

You should move in the Telegram group. Actually we’re more than 800 members and a lot of people could help you, as there are dozens of different FC and RC types used and known with specific solutions for your setup . As I don’t use a Crossfire, this is above my knowledge…

Ok, I will

I managed to make it work now.
To update this topic I explain how.

These are issues for Open.HD 2.x and they get resolved in 3.x releases.

According to Stephen Oliver: "there are 2 ways for rc channel values to be noticed by the air pi, the openhd RC system sending them to the camera switcher, and the camera switcher listening to mavlink messages. It only does the first one, it was never wired up to hear the channel values in 2.x "

So thats the reason why it will not work, if just the AirPi is connected to the flight controller, because the USB camera switcher can’t get the RC channel values from it yet.

However it will work, when connecting a joystick to the GroundPi and enable the telemetry uplink.
Then the USB camera switcher can get the RC channel values from the internal RC system and is able to switch.

The reason for this is, that the Arducam camera switcher is indeed listening on the mavlink connection to the flight controller and was set to channel 16 by default, therefore there was the cameras switching, but not the USB camera, but the Arducam switcher (that i don’t have), and it gets displayed by the AirPi.

So my claim was right, because the AirPi’s Arducam switcher does check the rc values of channel 16 over mavlink from the flight controller but not the USB camera switcher, as we found out.

I have tried it with RTL chips, but there is no difference. Both chipsets work the same.
This was also declared by Stephen. When the setup and the settings are correct, the card doesn’t matter.

So to make my setup work as intended I needed to connect my Taranis to the GroundPi as a joystick and enable TELEMETRY_UPLINK
Then the GroundPi is sending the RC Channels to the AirPi and the camera switching will work on the AirPi as well as on the GroundPi.
Then the AirPi does not have to be connected to the flight controller, when it is just used for video.