Can't connect to the phone via hotspot or tethering

Pi 4B GroundPi
Zero AirPi
RTL8812AU BearExtender Turbo
Zeus 722 FCC

I don’t know if the hardware I have is even capable of it, but I just can’t get the GroundPi to connect to my phone. I tried tethering first and it just never even registered that my phone was connected. I tried using different phones and cables, tried messing with the usb tethering settings, but nothing seems to work. I also tried hotspot but that also didn’t work. OpenHD never comes up in the list of available connection. I tried adjusting every setting I could but nothing worked. Auto, manual, different channels, etc… It says on the logs that there is no hotspot capable hardware found. What else should I try? Any help would be greatly appreciated.

Sounds like you have changed alot of stuff… instead of true troubleshooting I would just start over

Reset your settings by copying a fresh settings file or just reburn your image. Set everything up on your groundpi as if you will fly (wifi card plugged in, plug a display in- make sure osd appears and you can recieve video from airpi) to make sure things are working.

Then get on another device and search for the openhd hotspot. If you dont see it using your phone maybe try a laptop or other device. Default is “auto” which means on a pi4b plugged into that RTL8812AU (which in “auto” will be on 5.8g band) your wifi hotspot should be on 2.4g

Thank you for the quick response. I reflashed the sd cards with a fresh image. Wifi cards and display was plugged in. I received video and telemetry from the airpi just fine. I looked up for the openhd hotspot on 2 phones and a laptop. I still couldn’t find it. I checked the settings and hotspot was on auto. I tried doing usb tethering but that didn’t work either. I think I might have messed something up or overlooked something because I feel like it’s weird that neither one works. Is there a way I can troubleshoot this?

That is weird… the openhd hotspot should be there.

Too bad you have a zero for the air. I would recommend swapping your air and ground pi but a zero cannot do ground role…

I assume you are running openhd 2.0.8? The latest… ( I think)

Yes I am

Perhaps share some pictures of the messages that display on the groundpi as it starts up. In particular any messages regarding the hotspot

if you hook up a keyboard to your groundpi and hit ctrl-c you should be able to get to a terminal… from there its linux commands to troubleshoot the wifi

You could also get on telegram and get alot more interaction and advice…

Will do. I already got a keyboard and mouse connected to the ground. Nothing really happens when i hit ctrl-c though. Sorry I’m not super familiar with some of the simple things I should probably know.





OK I think I see your problem. You have a pi4 that is a new “model” of the pi4. The message that says “running on unknown system”

You arent doing anything wrong. And ultimately we can get your pi4b working but the actual openhd code needs an update

Oh I see. Thank you very much for the help. I’m not sure how much i can help with the code but I will certainly be waiting for the update!

In order to fix this we will need some help from you… we will need to know what pi4 “model” you have

After you help us with this detail…

Then 2 options:

A- we walk you through changing a couple lines of code

B- you wait for the next version of openhd which will have this change built in

Stephen is the guy that is really running the show these days- he might be thinking of doing an update to openhd in the near future. We might also want to wait for him to see these messages so he can weigh in. I am 90 percent sure I have identified the problem but I have been out of this side of of openhd for over a year ( I could not even instruct you correctly how to get to terminal since “ctl-c” did not work hahah)

Got it. This is my raspberry pi. I don’t know whether I can check the model through software, but this is what it looks like physically.

The openhd code identifies your pi internally… we have to find out what this new version is

you have to get to terminal and type

cat /proc/cpuinfo

write the output here… you are looking for “REVISION :”

in the example above it is a “d03114”

Write your model number down… and while still in the terminal you need to navigate to /wifibroadcast-scripts/global_functions.sh

So off top of head

cd home
cd pi
cd wifibroadcast-scripts

type “rw” to make image writeable

type to edit file-
sudo nano global_functions.sh

an editor should open up with code in it
scroll down within the file
looking for “function detect_hardware”

For reference in the repo it looks like this Open.HD/global_functions.sh at 00627dbd266e55c46a1bc784fc6f9535dcc73ca8 · OpenHD/Open.HD · GitHub

in that editor in terminal just replace one of the existing model numbers with yours… then exit the editor and save

Good luck

I’m still trying to get into the terminal. I’ve tried ctrl-c and alt-f12 but nothing came up.

I search in the gitbook and on telegram but nothing…

I asked in telegram…but noone has answered yet

try ctrl+alt+f3

I saw this on telegram from a search