Follow instructions and still no working OSD

I have followed the instructions yet the OSD still doesn’t work.

I have a video feed/stream. I get the temperatures and the bit rate etc etc from the AirPi and the GroundPi. No issue there.

I have a FC that I can connect to Mission Planner using a telemetry radio. No issue there. Using the telemetry radio on TLM1 on my FC.

I have checked the Tx and Rx pins on the GroundPi to the TLM2 ports. I think that is correct. I will cross them to double check they aren’t incorrectly connected. But I have read the pin-out so I think that is okay.

I’ve made the changes in ardupilot to the parameters for (in my case) sr2 as I am using TLM2.

I have tried baud rates: 57600, 115200 and 921600. Made changes to the FC_RC and FC_Telemetry Baud rates on the cards in the AirPi and GroundPi. Doesn’t change a thing. Still doesn’t work.

Can use either Mavlink 1 or 2? I have 1 selected.

What else am i ment to change? Are you sure this actually works? I have my doubts.

ardupilot stream rates?

What are stream rates? Serial Baudrates?

I have no idea what I am missing - says a lot about the instructions.

I am now trying to use OpenHD with a Pixhawk 2.4.8 FC. Is it ok to just have the FC connected to Mission Planner via USB cable and still connect a GroundPi and have telemetry able to pass? Sorry, I’m not a Legend like you guys, able to get a working OSD.

I’ve just got my setup working, hopefully i can help having had similar problems.

My problem was due to a incompatible wifi adapter but my setup wouldn’t give me the temperature of the air pi. It sounds like have this data, so could be just a connection/wiring problem.

The part of your initial post here suggests you’ve connected your flight controller telemetry port to your ground pi rather than the air unit?

What hardware are you using? flight controller, ground station, air unit, wifi adapters, power supply?

I have used a Cube black on a Kore Carrier Board. I have used the Cube on the original carrier board. I have used a Pixhawk. I have used a Raspberry Pi 3 Model 2 as Ground and Air. I have used Raspberry Pi 4 as Ground And Air. I have used a Pi 4 as Ground and Pi 3 as Air unit. I get video working on any of them. The basic telemetry from the Pi, I.e. CPU usage, temperature and strength is provided. I have used different wires for the connection between AirPi and FC TLM port.

I have tried different baudrates. I have tried different streams. (Why are the streams different? There are those in the settings and then there are those in an Expert Section. Different).

As far as I can tell there aren’t too much I that needs to change in order to get the OSD to work. I’m missing something. I guess all four Raspberry Pi’s could be damaged. Except they all stream video. I guess all four com ports on the pi’s could have gotten damaged.

I think I will install aversion of Raspbian and make sure they are all working properly. Start with that.

I wanted to know how I could check the data from the telemetry port on the flight controller is working or not, then see if this OpenHD works or not. How can I do that?

Could I please ask that if you are going to post a video on YouTube could you please take the time going over the settings showing them? It’s great to see it working but it really is of no help to any one. Really, some useful footage of settings and examples is all we really need.

The Flight Controller is a Pixhawk Cube. I have also borrow a Pixhawk from my relation to try the setup on. My Ground and Air Pi’s have been Raspberry Pi 3 Model B’s and 4’s. As of now I am using a Pi 4 for GroundPi with a Pi Power supply. 5.1V 3A. and for the AirPi a UBEC 5V 3A. The Pi’s I don’t think is the problem. I get video and basic operating data.

I’m going to check the FC by connecting an FTDI. I will check the pi’s using Raspbian and check the port. See if those are working so they can be ruled out

The flight controller looks like it has a 3.3v uart, so should be ok. Are you connecting as follows

Telem port FC - Air Pi
Pin 2 (TX) - Pin 10 RXD
Pin 3 (RX) - Pin 8 TXD
Pin 6 (GND) - Pin 6 GND or another gnd on the header.

I double checked everything was working using mavproxy, here are the steps i took.

  1. Downloaded & flashed sdcard with a clean pi os image

  2. Enabled the uart/serial port using raspi-config (with ssh disabled for this port)

  3. Installed MAVproxy

    sudo apt-get install python3-dev python3-opencv python3-wxgtk4.0 python3-pip python3-matplotlib
    python3-lxml python3-pygame
    pip3 install PyYAML mavproxy --user
    echo “export PATH=$PATH:$HOME/.local/bin” >> ~/.bashrc

  4. Start mavproxy and power the flight controller (taken from the default example on the maxproxy website) --baud=115200 --aircraft=“Quaddy” --speech --console --map --quadcopter

Hope this helps.