Mavlink telemetry do not work in INAV

Hi,
First,the new website is very beautiful,I like it,hope for more people coming here.

I met a problem when I try OPENHD in INAV.
If I set the telemetry to LTM and the band is 115200,it can work(half),the attitude shows fine but there is no battery info no GPS info no speed no distance info,all information show 0 except attitude.
Then I try to set telemetry to Mavlink and the band is also 115200,nothing works.
so whats my problem?

FC:MATEKF722MINI
AIRPI:3A
GNDPI:3B+
VER:2.0.0 RC7 [Stretch]

Another question,does these hardware can run Buster img or it only support pi4?

Telemetry from iNav is always an issue for some reason, I know softserial ports seem to cause problems, and make sure the settings files exactly match on air and ground, including osdconfig.txt which has a setting at the top for ltm/mavlink.

I’ve never been able to get iNav to send telemetry out of the uart that I have soldered my pi wiring to, so it’s difficult to test here at the moment

I use Inav and mavlink telemetry in a Matek f405ctr, and it work, maybe not perfect, but almost: voltage, current, gps position,… Only problems with flight modes.
I use one uart for tx and other for rx (i use rc with openHd and Atheros card, so two uarts needed).
Only wiring and select in inav mavlink telemetry (115200).
In osdconfig.txt minor changes: select mavilink telemetry, and compass inav set to true
With 2.0.0 stable version and 09/09 version. (and with last release i think too, but only one flight with it before I meet a tree ).
In my setup in Inav Configurator:
uart1: mavlink telemetry to pi
uart2: ibus rc to pi
uart3: (Lidar)
uart4: gps matek
uart5: (optical flow)
scl-sda: compas (gps matek).
enble telemetry output.

With LTM i have always problems (distance…)

1 Like

Did you set RC=ibus or something else for iNav?

Yes, I use rc: ibus.

I use atheros card and it work with all inav versions and all openhd versions (few things to change, and some things wrong, but for me ok):

In Inav:
set mavlink telemetry 115200
set rx ibus 115200 in other uart.
in config page: select show telemetry

In openhd.txt
set frecuency and datarate
rc: ibus
check same speed 115200 for rc and telemetry
cts:Y and encryption : range (but this is with atheros, don´t know with others…it must work…)
In openhd osd.txt:
set telemetry: mavlink.

Turn on gruond pi, and when it show image connect to Taranis usb (in my case) and click ok .
Turn on air pi and when runnig ok, connect to inav to see rc signals.