No HDMI to Fatshark goggles

FIXED! Had a faulty HDMI to HDMI micro adapter… All working fine now!

When I connect the HDMI from my ground PI4B to my TV, everything works fine, I see video and telemetry from the Air PI. But when I connect it to my Fatshark HDO or Fatshark HD2 I get no picture. The HDMI of both goggles work fine if I, for example, connect my laptop to the goggles, I have a picture. I have tried the hdmi_safe = 1 in the config.txt, without success. Also the hdmi_force_hotplug = 1 did not work. config_hdmi_boost = 4 neither. And tested all possible other output options, anyway, no picture in the Fatshark goggles.
Have tried powering the PI with USB-C, and with a power supply at 5.1v @ 5Amp to the GPIO. And with nothing else connected to the PI. HDMI works on the TV, not on the Fatsharks…
Anyone an idea? I’m clueless…

Oh, when I connect the Fatshark to the AirPi (Pi Zero), I do get a picture! Just text scrolling by, but still a picture…

It has worked on both my HD2 and HDO2 fatsharks. My only question is are you also turning the receiver switch off in addition to putting it in HDMI mode?

Thanks for the suggestion.
Yes, and even with no receiver plugged in at al.
When I use another HDMI source, the goggles work fine.
I hava an old PI from 2012 and I get a picture out of that one into my goggles.

FIXED! Had a faulty HDMI to HDMI micro adapter… All working fine now!

Good to hear.
Two things I’ve learned with the Fatshark goggles,

  1. the HDMI port is not that robust, I’ve pulled the pins completely out of one, so if you can rig up some sort of strain relief on the connection it will be beneficial, and
  2. the HDMI card will stop working and need to be replaced if you forget and and leave the battery plugged in till it runs down…guess how I know.

Good to know!
I’ll keep that in mind!

This is what I use on my Fatsharks.