No video Asus AC-56

Hello this is only my 2nd post and I am attempting to get a rig set up on the bench before going any further.

I have spent all weekend trying to get video to work but after 2 full days I can’t get an image to come on the ground station. I can see the OSD and the status shows everything has started correctly on the ground station. Although in the about section it doesn’t seem to have any data about the air station.

I have followed the instructions regarding providing power to the Wifi adapters, checked, double checked my soldering and connections but I simply can’t get it to work, and I am about to give up after spending a fair few pounds on WIFI cards and a camera for the PI.

I am convinced its on the Air end that I have the problem but I don’t know how to troubleshoot the Pi Zero.

If anyone could offer any advice, I would be very grateful.

Hello, the ac56 lights blue? Does the camera light up the led?

If you have modified the config file, upload it to check

Hi thanks for replying, the lights on the ac-56’s are on, I’ve not modified anything, just imaged the sd cards with Etcher and put them
In the PI’s.

All the videos I’ve seen just shows that “it just works”… after following the precautions. But it’s like I’m Missing something like pairing the air and ground but I can’t see that you have to do that.

The only thing that I could modify now if the length of the usb lead I made for the ground station, this one delivers data from the USB socket and power from the UBEC, it is a bit on the long side, but I struggle to imagine that it would cause no comms at all.

The one thing that comes to my mind is a previous mentioned bug that causes a layer shift. You can check by connecting a mouse to the groundstation and clicking continuously in the empty area between the widgets until it changes in stereo mode. You should now see „some“ video. Could you check ?

I’m still not having any luck, and I’ve literally gone text book setup, I have now reduced the size of the USB leads, powered via UBEC and via variable 10A psu but the result is the same… nothing. I’m beginning to wonder if the AC-56 adapters are different to those mentioned on here as they are brand new? I enclose some pictures more pics if anyone has any inspiration, the one of the big screen is the Air PI with the mini HDMI plugged in, not sure what it all means but It looks lke its detected the camera and is streaming something? I’m not bad with linux so if there is anything I can do there to troubleshoot / debug i will have a go.

For some reason your video bitrate seems very high. Default settings normally result in ~4MB/s. And you got over 25.
Can you try and set


In the settings file and see if it does something?

Hi CopterGUI

I’ve made those changes and it has set the bitrate now to fixed 4000 kBit/s on the Air end, but no video is coming over to the ground station.

Looking at the ground station “About” section it constantly shows OpenHD Version: Checking… under the Air section, its like it int seeing the Air station at all.

I really appreciate all the help so far. Do you think it could be the Wifi cards? perhaps they have updated the chipset recently?

I remembered I had an original Pi buried away in a dusty corner, one of the 1st ones so I fired that up with the same sdcard (with converter) plugged the wifi card in direct to the pi without powering seperately (thought it could do no harm), camera attached, fired it up and hey presto… worked 1st time. It took a fair while to boot but this is to be expected given the age of the Pi.

I am left puzzled why its not working on the Zero now, the image must be ok, I know the Wifi cards work and the camera works. Could it be a defective Zero (seems to work, display, ssh etc). I have also connected a keyboard to the USB cable I made on the Zero and that inputed keystrokes o the Zero, so the data wires are correctly wired.

I ran an image of OctoPi on the Zero and I could see and image from the camera.

What I didnt want to do was open the Wifi cards up to hard wire before I confirmed a working setup, but I guess now I am left no choice, the only other thing I can do is hard wire them to the Zero and see if that helps?

Its not completely unheard of for a zero to be faulty…

Thanks everyone for your tips and guidance, I have learnt a lot. I got it figured out today, I went over each of the camera connector pins with my Hakko thin tip soldering iron using a microscope and re soldered the pins on the Pi0.

Now it works as expected 1st time no bother at all and getting good results. Interestigly the video bitrate seems to be fine now using the Auto setting.

Time to get the AC-56’s open and hard wired into a frame.

1 Like

Nice it’s working now :+1: