Telem not being displayed in OSD

I have (2) Pi 3s with a Pixhawk FC and use QGroundControl and FPV-VR on the ground. I can’t get the telemetry data to appear on either app’s OSD. The packets seem to have a high drop off rate. I have checked all setting on the app side for the right ports and selected Mavlink. I’m wondering on the OSD .txt file if I need to remove all the # before each line i.e. define MAVLINK line. I’m rusty with coding as I don’t do it often.


Nevermind, Fixed it. Had to adjust the stream rate on the Pixhawk

Can you share your settings? I’m not getting a working OSD. I have read over the instructions. I don’t know if it’s me, the software or the hardware. It just doesn’t work.

I can connect a telemetry radio to either port TLM1 or TLM2 on the Carrier Board (I’m using a Cube Black on a Kore Carrier Board) and connect to it using Mission Planner. Getting the OSD work on the Monitor using OpenHD is another thing.

Am I meant to use the AirPi connected to TLM1? An Ardupilot Companion Computer info page mentions to use TLM2 and baud rate of 921600. I tried that. It didn’t work. Set to a couple of other baud rates don’t do anything either.

What did you do to get this to work? I’m not a computer programmer. I don’t always catch all the tips and tricks. Just lay it out point by point if you can - like the instructions should be doing in the first place.

Thanks if you can help with this.

on the hardware side make sure you connect Tx from Airpi to Pixhawk Rx and vice versa. In my ignorance it needs both Tx and Rx lines to communicate with each other. Im not familiar with the Cube but on the Pixhawk 1 the voltage lines are already low at 3.3 v.
Try adjusting the stream rates in Mission Planner as mentioned in this:

Do we use the baudrate in Communicating with Raspberry Pi via MAVLink, which is 921600? Or do we use 57600 or 115200?

for my Pixhawk, I use either 57600 or 115k. I think 921600 is too fast. I haven’t tried it yet. Are all your sensors showing? I had a problem with some sensors not showing. Here’s the link to explain it a bit