Video working but OSD not working


I’ve got open-hd setup and working for video transmission but I’m having a few problems getting mavlink data to drive the OSD from my flight controller. I’ve connected the pixracer telemetry port 1 to the pi0 uart0 (pins 8 & 10) and confirm with a scope that the tx & rx pin are the correct, also tried changing the baud rates.

Any ideas what could be causing this problem or ways to debug the telemetry data?

in the air:
flight controller: pixracer (ardupilot installed)
pi zerow
mediatek 8812au

ground station
pi4 2gb
mediatek 8812bu (didn’t think this would work but seems ok on the ground station)

Same. Camera works but the OSD does not.

New Arducopter installed. New OpenHD installed.

The camera works. Telemetry Radios work.

OSD Telemetry does not work.

Rx and Tx connected from AirPi to TLM1 port on my FC. Am I right to assume the setting or this port in Ardupilot is Serial1?

The telemetry radio is connected to TLM2 on my FC.

I have tried both 57600 and 115200 Baud.

Anyone have this working with Ardupilot yet? Be nice if you could share what you did. I see so many videos on youtube showing it working but not too many wanting to lay down what setting and exact sets they did getting it to work.

When this is working (I don’t hold much hope) I will post a video with images and steps pointing out what your settings need to be, instead of the cryptic messages we currently need to follow. Maybe that will help future noobs out. Lord knows the current instructions don’t.

Glad to hear i’m not the only one having problems :slight_smile:

I’ve been looking into this a little more but nothing working yet.

It looks like the pi zerow is receiving data from the flight controller at 115200, lots of none ascii data but
the serial port is ok and I’ve confirmed that the data transmit rates are all ok in ardupilot, as per the wiki page.

The ground station pi isn’t receiving any data in the OSD FIFO but I’m not sure if this is due to the ground pi not receiving or the air pi not transmitting.

I think this problem could be due to my wifi adapter on the ground station not being 100% compatible (RTL8812BU), smart sync fails at boot up, probably because it’s unable to transmit. I’ve ordered another RTL8812AU adapter to see if it solves these problems.

Many thanks


The 8812bu is the problem in this case

I will keep repeating my mantra when it comes to telemetry and ardupilot… Be sure to check your stream rate params on your flight controller. It will be Sr1 if you are outputting telemetry on serial 1, Sr2 for serial 2 and so on…

I’ve setup the ardupilot data rate as per the following wiki page.

I wanted to double check that everything was configured correctly, so i downloaded a clean pi image, installed mavproxy & configured the serial port. This worked perfectly so this proves out my ardupilot setup and wiring.

So hopefully the new 8812au adapter gets everything working, just waiting for it to turn up in the post.

Just to confirm, my new wifi adapter arrived today and my video and OSD are now working perfectly.

Many thanks for the support and very excited about getting it in the air :smile:

1 Like