Open HD not Booting on Zero 2 W

I have just received a Zero 2 W and attempted to boot Open HD but it will not run, no SD card LED activity and nothing on HDMI either, i have also tired Ruby with the same behavior, well lack of it to be more accurate!

Does anyone have any suggestions?

Steve.

2 Likes

Do you see no infos on the screen while booting up? No color testpattern?
Have you tried the stock RPI OS to confirm your module + setup is ok?

The standard OpenHD image definitely does not boot on a Pi Zero 2. However, after a fair amount of fiddling I’ve managed to make it work, albeit with no real testing yet so there may be some hidden problems that I’ve not seen yet, because they’re hidden :slight_smile:

So I’d be a little cautious about using it before more testing is done…

Anyway, it’s actually fairly simple to fix. The problem appears to be that the new machine/processor combination requires a different set of low level boot files to start up. This can be achieved by the following process.

  1. Create an OpenHD SD card in the usual way. Put it to one side.
  2. Create a standard Raspbian SD card with the latest version of Raspbian in the usual way. Check it boots the Zero 2 correctly.
  3. Copy the contents of the boot partition of that card to somewhere on your PC.
  4. Copy the contents of the boot partition of the OpenHD card to somewhere safe as well.
  5. Copy the following files from the Raspbian card boot partition to the OpenHD card boot partition, overwriting the files that are already there:

bootcode.bin
*.dat
*.dtb
*.elf

Leave everything else alone. The card you’ve modified should now boot on the Zero 2 W without problems.

This is rather a brute force method and it probably only needs a few of these files in actuality, but it works and should be a good starting point.

My initial impression is that the video latency on the Zero 2 is considerably less than on the older version of the Zero, but again I’ve literally only got it working in the last half hour and haven’t had time to really test this!

Good luck :slight_smile:

Oh yes, if you want to revert to the old version of the card, just delete the contents of the boot partition and put back the one you saved.

3 Likes

Thanks for your research and documentation :+1: Do you think it’s worth to already mention on the supported modules wiki page?

I now have a zero 2 booting as ground, im a happy bunny!

please help , my zero 2W not booting. I rewrite all
bootcode.bin
*.dat
*.dtb
*.elf
I use Open.HD-2.0.12b-buster.

I’m out roller-skating at the moment so can’t post the files but if your still having trouble when I get home I’ll link the files I used.

Thanks for your help.

Here are the files i used to get the Zero 2 working, it boots as Air or ground :slight_smile:
Sorry its in 4 parts for OpenHD 2.0.8 - zero 2 w (1),(2),(3) and (4), this forum wont let me upload it in one file, extract the files and paste them into your SD card and choose to replace any files it says already exist.

The file named 2.0.12b is obviously for OpenHD 2.0.12b, i have only tried 2.0.8 so the files for 2.0.12b have not been tested by me.

I found that doing a fresh install and then pasting the files BEFORE a boot attempt had the best success

Zero2W for 2.0.12b.zip (40.5 KB)
Zero 2 W (1).zip (2.4 MB)
Zero 2 W (2).zip (10.0 MB)
Zero 2 W (2).zip (9.5 MB)
Zero 2 W (3).zip (9.4 MB)

1 Like

You copied almost everything with Raspbian, didn’t you?

Those are the files the devs say are required.

I’m not doing well.

have you tried using 2.0.8 if your having issues getting 12b to work?

He tried without success. When I create an OPENHD 2.0.8 image buster, the boot LED does not light - it does not boot. When I create an OPENHD 2.0.12 image buster, the boot LED lights up but the system does not boot. When I copy OPENHD 2.0.8 with an image buster and overwrite the files you sent me, it doesn’t boot either. Raspbian on RPI zero 2w image booting well.

On my RPI Zero WH OPENHD buster 2.012 booting and all working well.

Hi.

I’ve uploaded the appropriately modified boot directory for v2.0.8 as a zip file, which has been tested to work on a zero 2 W.

Link to zipped boot partition contents

Try that. Download it, unzip it, and copy it over the top of the boot partition on a freshly created 2.0.8 OpenHD microSD card. It should work for you then.

1 Like

I don’t know what I’m doing wrong anymore. I upload the image of OPENHD buster 2.0.8 via Win32 disk imager to micro SD. Then I will overwrite the files you sent me in windows exlorer and it won’t boot anyway.

But still, thank you for your help.

Just for info, this is my RPI Zero 2W board
I’m sorry, but my RPI Zero 2W is already booting and OPEN HD 2.0.8 is working. One more thank you for all your help. :grinning:

.

1 Like

how did you solved it? i’m struggling also. Installed fresh buster image 2.0.8 and overwrited the extracted zip files from @pcats.

it’s booting and i’m getting image for couple seconds but it drops out and also Qopen.HD app overlay is not loading.

RPI 2W probably has more current consumption, try another power supply or cable, I already have it powered via a 5.15V stepdown and it runs correctly without problems.

Here is my test kit with ASUS AC56 before connecting to the model.